package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(thank-you$)|(thank-you\?)|(thank-you\/\?)`)
var str = `thank-you
thank
thank-you?
thank-you-for
thank-you/again
thank-you/?
aries-thank-you`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}