$re = '/(thank-you$)|(thank-you\?)|(thank-you\/\?)/m';
$str = 'thank-you
thank
thank-you?
thank-you-for
thank-you/again
thank-you/?
aries-thank-you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);