using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(thank-you$)|(thank-you\?)|(thank-you\/\?)";
string input = @"thank-you
thank
thank-you?
thank-you-for
thank-you/again
thank-you/?
aries-thank-you";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}