import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(thank-you$)|(thank-you\\?)|(thank-you\\/\\?)";
final String string = "thank-you\n"
+ "thank\n"
+ "thank-you?\n"
+ "thank-you-for\n"
+ "thank-you/again\n"
+ "thank-you/?\n"
+ "aries-thank-you";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}