import Foundation
let pattern = #"\.(\w*)$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://www.style-for-u.com/wp-content/uploads/2014/08/T-shirt-femme-imprim%C3%A9-voilier-Petit-Bateau-env-50%E2%82%AC.jpg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"-150x150.$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}