#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\.(\w*)$"
Local $sString = "http://www.style-for-u.com/wp-content/uploads/2014/08/T-shirt-femme-imprim%C3%A9-voilier-Petit-Bateau-env-50%E2%82%AC.jpg"
Local $sSubst = "-150x150.$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)