using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.(\w*)$";
string substitution = @"-150x150.$1";
string input = @"http://www.style-for-u.com/wp-content/uploads/2014/08/T-shirt-femme-imprim%C3%A9-voilier-Petit-Bateau-env-50%E2%82%AC.jpg";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}