const regex = /\.(\w*)$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\.(\\w*)$', '')
const str = `http://www.style-for-u.com/wp-content/uploads/2014/08/T-shirt-femme-imprim%C3%A9-voilier-Petit-Bateau-env-50%E2%82%AC.jpg`;
const subst = `-150x150.$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);