// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\.(\w*)$").unwrap();
let string = "http://www.style-for-u.com/wp-content/uploads/2014/08/T-shirt-femme-imprim%C3%A9-voilier-Petit-Bateau-env-50%E2%82%AC.jpg";
let substitution = "-150x150.$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}