use strict;
my $str = 'http://www.style-for-u.com/wp-content/uploads/2014/08/T-shirt-femme-imprim%C3%A9-voilier-Petit-Bateau-env-50%E2%82%AC.jpg';
my $regex = qr/\.(\w*)$/p;
my $subst = '-150x150.$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";