re = /^[^:\n]+(?=:.+)/m
str = 'func factorial{num
if{num==1
ret{1}
}
ret{num*factorial{num-1}}
}
p:style="color: Red;"{factorial{fromVars{"target"}}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end