$re = '/^[^:\n]+(?=:.+)/m';
$str = 'func factorial{num
if{num==1
ret{1}
}
ret{num*factorial{num-1}}
}
p:style="color: Red;"{factorial{fromVars{"target"}}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);