import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^:\\n]+(?=:.+)";
final String string = "func factorial{num\n"
+ " if{num==1\n"
+ " ret{1}\n"
+ " }\n"
+ " ret{num*factorial{num-1}}\n"
+ "}\n"
+ "p:style=\"color: Red;\"{factorial{fromVars{\"target\"}}}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}