const regex = new RegExp('^[^:\\n]+(?=:.+)', 'gm')
const str = `func factorial{num
if{num==1
ret{1}
}
ret{num*factorial{num-1}}
}
p:style="color: Red;"{factorial{fromVars{"target"}}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}