#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^:\n]+(?=:.+)"
Local $sString = "func factorial{num" & @CRLF & _
" if{num==1" & @CRLF & _
" ret{1}" & @CRLF & _
" }" & @CRLF & _
" ret{num*factorial{num-1}}" & @CRLF & _
"}" & @CRLF & _
"p:style="color: Red;"{factorial{fromVars{"target"}}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")