using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^:\n]+(?=:.+)";
string input = @"func factorial{num
if{num==1
ret{1}
}
ret{num*factorial{num-1}}
}
p:style=""color: Red;""{factorial{fromVars{""target""}}}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}