// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:uid=(?<uid>\d{6}),)?ou=(?<ou>\d{6}),dc=placetel,dc=de$").unwrap();
let string = "ou=200000,dc=placetel,dc=de
uid=231001,ou=200000,dc=placetel,dc=de
uid=231001,uid=231001,ou=200000,dc=placetel,dc=de
dc=placetel,dc=de
ou=200000,dc=placetel,dc=com
cn=admin,dc=placetel,dc=de";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}