#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:uid=(?<uid>\d{6}),)?ou=(?<ou>\d{6}),dc=placetel,dc=de$"
Local $sString = "ou=200000,dc=placetel,dc=de" & @CRLF & _
"uid=231001,ou=200000,dc=placetel,dc=de" & @CRLF & _
"uid=231001,uid=231001,ou=200000,dc=placetel,dc=de" & @CRLF & _
"dc=placetel,dc=de" & @CRLF & _
"ou=200000,dc=placetel,dc=com" & @CRLF & _
"cn=admin,dc=placetel,dc=de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")