re = /^(?:uid=(?<uid>\d{6}),)?ou=(?<ou>\d{6}),dc=placetel,dc=de$/m
str = 'ou=200000,dc=placetel,dc=de
uid=231001,ou=200000,dc=placetel,dc=de
uid=231001,uid=231001,ou=200000,dc=placetel,dc=de
dc=placetel,dc=de
ou=200000,dc=placetel,dc=com
cn=admin,dc=placetel,dc=de'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end