# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:uid=(?<uid>\d{6}),)?ou=(?<ou>\d{6}),dc=placetel,dc=de$"
test_str = ("ou=200000,dc=placetel,dc=de\n"
"uid=231001,ou=200000,dc=placetel,dc=de\n"
"uid=231001,uid=231001,ou=200000,dc=placetel,dc=de\n"
"dc=placetel,dc=de\n"
"ou=200000,dc=placetel,dc=com\n"
"cn=admin,dc=placetel,dc=de")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.