const regex = /^(?:uid=(?<uid>\d{6}),)?ou=(?<ou>\d{6}),dc=placetel,dc=de$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:uid=(?<uid>\\d{6}),)?ou=(?<ou>\\d{6}),dc=placetel,dc=de$', 'gm')
const str = `ou=200000,dc=placetel,dc=de
uid=231001,ou=200000,dc=placetel,dc=de
uid=231001,uid=231001,ou=200000,dc=placetel,dc=de
dc=placetel,dc=de
ou=200000,dc=placetel,dc=com
cn=admin,dc=placetel,dc=de`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}