import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:uid=(?<uid>\\d{6}),)?ou=(?<ou>\\d{6}),dc=placetel,dc=de$";
final String string = "ou=200000,dc=placetel,dc=de\n"
+ "uid=231001,ou=200000,dc=placetel,dc=de\n"
+ "uid=231001,uid=231001,ou=200000,dc=placetel,dc=de\n"
+ "dc=placetel,dc=de\n"
+ "ou=200000,dc=placetel,dc=com\n"
+ "cn=admin,dc=placetel,dc=de";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}