import Foundation
let pattern = #"(?<=[\.?!]\s|^)([a-z])|(\bi(?=\b|'))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand.
why am i short? it's not lke i'm not eating or anything, i'm just short!
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\U$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)