import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\\.?!]\\s|^)([a-z])|(\\bi(?=\\b|'))";
final String string = "the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand.\n\n"
+ "why am i short? it's not lke i'm not eating or anything, i'm just short!";
final String subst = "\\U$0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}