using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\.?!]\s|^)([a-z])|(\bi(?=\b|'))";
string substitution = @"\U$0";
string input = @"the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand.
why am i short? it's not lke i'm not eating or anything, i'm just short!";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}