re = /(?<=[\.?!]\s|^)([a-z])|(\bi(?=\b|'))/m
str = 'the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand.
why am i short? it\'s not lke i\'m not eating or anything, i\'m just short!'
subst = '\\U$0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result