# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[\.?!]\s|^)([a-z])|(\bi(?=\b|'))/\U$0/gm;t' <<< "the quick brown fox jumped over the lazy dog. the dog did not like this! why would the fox jump over him? the dog did not understand.
why am i short? it's not lke i'm not eating or anything, i'm just short!"