// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)( \w+) +(\w+) *(\[\])=\[(.+)\] *;").unwrap();
let string = " //Общий звук броска
public static TSound ThrowSound []=[BM.SoundLoad(\"_Incbin/Sounds/Throw\")];
private int BloodColor[]=[100,10,10] ;// Цвет крови игрока
Local ShadowDistance[]=[-2,-2];
Local ShadowColor[]=[15,57,12];// уже *2
//x y z
private int PrimHandPos[]=[2,2,8];
private int SecHandPos[]=[1,-1,8];
private int CrawlHandPos[]=[2,0,2];
";
let substitution = "$1[] $2 = {$4};";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}