# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"( \w+) +(\w+) *(\[\])=\[(.+)\] *;"
test_str = (" //Общий звук броска\n"
" public static TSound ThrowSound []=[BM.SoundLoad(\"_Incbin/Sounds/Throw\")];\n"
" \n"
" private int BloodColor[]=[100,10,10] ;// Цвет крови игрока\n\n"
" Local ShadowDistance[]=[-2,-2];\n"
" Local ShadowColor[]=[15,57,12];// уже *2\n\n"
" //x y z\n"
" private int PrimHandPos[]=[2,2,8];\n"
" private int SecHandPos[]=[1,-1,8];\n"
" private int CrawlHandPos[]=[2,0,2];\n"
" ")
subst = "$1[] $2 = {$4};"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.