package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)( \w+) +(\w+) *(\[\])=\[(.+)\] *;`)
var str = ` //Общий звук броска
public static TSound ThrowSound []=[BM.SoundLoad("_Incbin/Sounds/Throw")];
private int BloodColor[]=[100,10,10] ;// Цвет крови игрока
Local ShadowDistance[]=[-2,-2];
Local ShadowColor[]=[15,57,12];// уже *2
//x y z
private int PrimHandPos[]=[2,2,8];
private int SecHandPos[]=[1,-1,8];
private int CrawlHandPos[]=[2,0,2];
`
var substitution = "$1[] $2 = {$4};"
fmt.Println(re.ReplaceAllString(str, substitution))
}