re = /( \w+) +(\w+) *(\[\])=\[(.+)\] *;/m
str = ' //Общий звук броска
public static TSound ThrowSound []=[BM.SoundLoad("_Incbin/Sounds/Throw")];
private int BloodColor[]=[100,10,10] ;// Цвет крови игрока
Local ShadowDistance[]=[-2,-2];
Local ShadowColor[]=[15,57,12];// уже *2
//x y z
private int PrimHandPos[]=[2,2,8];
private int SecHandPos[]=[1,-1,8];
private int CrawlHandPos[]=[2,0,2];
'
subst = '$1[] $2 = {$4};'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result