const regex = /( \w+) +(\w+) *(\[\])=\[(.+)\] *;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('( \\w+) +(\\w+) *(\\[\\])=\\[(.+)\\] *;', 'gm')
const str = ` //Общий звук броска
public static TSound ThrowSound []=[BM.SoundLoad("_Incbin/Sounds/Throw")];
private int BloodColor[]=[100,10,10] ;// Цвет крови игрока
Local ShadowDistance[]=[-2,-2];
Local ShadowColor[]=[15,57,12];// уже *2
//x y z
private int PrimHandPos[]=[2,2,8];
private int SecHandPos[]=[1,-1,8];
private int CrawlHandPos[]=[2,0,2];
`;
const subst = `$1[] $2 = {$4};`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);