#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)( \w+) +(\w+) *(\[\])=\[(.+)\] *;"
Local $sString = " //Общий звук броска" & @CRLF & _
" public static TSound ThrowSound []=[BM.SoundLoad("_Incbin/Sounds/Throw")];" & @CRLF & _
" " & @CRLF & _
" private int BloodColor[]=[100,10,10] ;// Цвет крови игрока" & @CRLF & _
"" & @CRLF & _
" Local ShadowDistance[]=[-2,-2];" & @CRLF & _
" Local ShadowColor[]=[15,57,12];// уже *2" & @CRLF & _
"" & @CRLF & _
" //x y z" & @CRLF & _
" private int PrimHandPos[]=[2,2,8];" & @CRLF & _
" private int SecHandPos[]=[1,-1,8];" & @CRLF & _
" private int CrawlHandPos[]=[2,0,2];" & @CRLF & _
" "
Local $sSubst = "$1[] $2 = {$4};"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)