import Foundation
let pattern = #"(.*)\n(\d*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Banana
67
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"My name is $1 and I am $2 years old."#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)