const regex = /(.*)\n(\d*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*)\\n(\\d*)', 'gm')
const str = `Banana
67`;
const subst = `My name is $1 and I am $2 years old.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);