#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*)\n(\d*)"
Local $sString = "Banana" & @CRLF & _
"67"
Local $sSubst = "My name is $1 and I am $2 years old."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)