use strict;
my $str = 'Banana
67';
my $regex = qr/(.*)\n(\d*)/mp;
my $subst = 'My name is $1 and I am $2 years old.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";