package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.*)\n(\d*)`)
var str = `Banana
67`
var substitution = "My name is $1 and I am $2 years old."
fmt.Println(re.ReplaceAllString(str, substitution))
}