import Foundation
let pattern = #"(?:'(views\/[^']*)'|"(views\/[^"]*)")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
return {
dayNames: $(dayKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/days/full/" + val);
}).toArray(),
dayNamesMin: $(dayKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/days/abrv/" + val);
}).toArray(),
monthNames: $(monthKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/months/full/" + val);
}).toArray(),
monthNamesShort: $(monthKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/months/abrv/" + val);
}).toArray(),
hourText: Console.globalize.globalizeMessage("views/common/dates/text/hour"),
minuteText: Console.globalize.globalizeMessage("views/common/dates/text/minute"),
secondText: Console.globalize.globalizeMessage("views/common/dates/text/second"),
millisecText: Console.globalize.globalizeMessage("views/common/dates/text/millisecond"),
microsecText: Console.globalize.globalizeMessage("views/common/dates/text/microsecond"),
timeSuffix: Console.globalize.globalizeMessage("views/common/dates/text/time-suffix"),
yearSuffix: Console.globalize.globalizeMessage("views/common/dates/text/year-suffix"),
timeText: Console.globalize.globalizeMessage("views/common/dates/text/time"),
timeOnlyTitle: Console.globalize.globalizeMessage("views/common/dates/text/time-only-title"),
currentText: Console.globalize.globalizeMessage("views/common/dates/text/now"),
closeText: Console.globalize.globalizeMessage("views/common/dates/text/close"),
closeText: Console.globalize.globalizeMessage('views/common/dates/text/close')
};
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)