$re = '/(?:\'(views\/[^\']*)\'|"(views\/[^"]*)")/i';
$str = 'return {
dayNames: $(dayKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/days/full/" + val);
}).toArray(),
dayNamesMin: $(dayKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/days/abrv/" + val);
}).toArray(),
monthNames: $(monthKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/months/full/" + val);
}).toArray(),
monthNamesShort: $(monthKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/months/abrv/" + val);
}).toArray(),
hourText: Console.globalize.globalizeMessage("views/common/dates/text/hour"),
minuteText: Console.globalize.globalizeMessage("views/common/dates/text/minute"),
secondText: Console.globalize.globalizeMessage("views/common/dates/text/second"),
millisecText: Console.globalize.globalizeMessage("views/common/dates/text/millisecond"),
microsecText: Console.globalize.globalizeMessage("views/common/dates/text/microsecond"),
timeSuffix: Console.globalize.globalizeMessage("views/common/dates/text/time-suffix"),
yearSuffix: Console.globalize.globalizeMessage("views/common/dates/text/year-suffix"),
timeText: Console.globalize.globalizeMessage("views/common/dates/text/time"),
timeOnlyTitle: Console.globalize.globalizeMessage("views/common/dates/text/time-only-title"),
currentText: Console.globalize.globalizeMessage("views/common/dates/text/now"),
closeText: Console.globalize.globalizeMessage("views/common/dates/text/close"),
closeText: Console.globalize.globalizeMessage(\'views/common/dates/text/close\')
};';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);