import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:'(views\\/[^']*)'|\"(views\\/[^\"]*)\")";
final String string = "return {\n"
+ " dayNames: $(dayKeys).map(function(i, val){\n"
+ " return Console.globalize.globalizeMessage(\"views/common/dates/days/full/\" + val);\n"
+ " }).toArray(),\n"
+ " dayNamesMin: $(dayKeys).map(function(i, val){\n"
+ " return Console.globalize.globalizeMessage(\"views/common/dates/days/abrv/\" + val);\n"
+ " }).toArray(),\n"
+ " monthNames: $(monthKeys).map(function(i, val){\n"
+ " return Console.globalize.globalizeMessage(\"views/common/dates/months/full/\" + val);\n"
+ " }).toArray(),\n"
+ " monthNamesShort: $(monthKeys).map(function(i, val){\n"
+ " return Console.globalize.globalizeMessage(\"views/common/dates/months/abrv/\" + val);\n"
+ " }).toArray(),\n"
+ " hourText: Console.globalize.globalizeMessage(\"views/common/dates/text/hour\"),\n"
+ " minuteText: Console.globalize.globalizeMessage(\"views/common/dates/text/minute\"),\n"
+ " secondText: Console.globalize.globalizeMessage(\"views/common/dates/text/second\"),\n"
+ " millisecText: Console.globalize.globalizeMessage(\"views/common/dates/text/millisecond\"),\n"
+ " microsecText: Console.globalize.globalizeMessage(\"views/common/dates/text/microsecond\"),\n"
+ " timeSuffix: Console.globalize.globalizeMessage(\"views/common/dates/text/time-suffix\"),\n"
+ " yearSuffix: Console.globalize.globalizeMessage(\"views/common/dates/text/year-suffix\"),\n"
+ " timeText: Console.globalize.globalizeMessage(\"views/common/dates/text/time\"),\n"
+ " timeOnlyTitle: Console.globalize.globalizeMessage(\"views/common/dates/text/time-only-title\"),\n"
+ " currentText: Console.globalize.globalizeMessage(\"views/common/dates/text/now\"),\n"
+ " closeText: Console.globalize.globalizeMessage(\"views/common/dates/text/close\"),\n"
+ " closeText: Console.globalize.globalizeMessage('views/common/dates/text/close')\n"
+ " };";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}