// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)(?:'(views\/[^']*)'|"(views\/[^"]*)")"#).unwrap();
let string = "return {
dayNames: $(dayKeys).map(function(i, val){
return Console.globalize.globalizeMessage(\"views/common/dates/days/full/\" + val);
}).toArray(),
dayNamesMin: $(dayKeys).map(function(i, val){
return Console.globalize.globalizeMessage(\"views/common/dates/days/abrv/\" + val);
}).toArray(),
monthNames: $(monthKeys).map(function(i, val){
return Console.globalize.globalizeMessage(\"views/common/dates/months/full/\" + val);
}).toArray(),
monthNamesShort: $(monthKeys).map(function(i, val){
return Console.globalize.globalizeMessage(\"views/common/dates/months/abrv/\" + val);
}).toArray(),
hourText: Console.globalize.globalizeMessage(\"views/common/dates/text/hour\"),
minuteText: Console.globalize.globalizeMessage(\"views/common/dates/text/minute\"),
secondText: Console.globalize.globalizeMessage(\"views/common/dates/text/second\"),
millisecText: Console.globalize.globalizeMessage(\"views/common/dates/text/millisecond\"),
microsecText: Console.globalize.globalizeMessage(\"views/common/dates/text/microsecond\"),
timeSuffix: Console.globalize.globalizeMessage(\"views/common/dates/text/time-suffix\"),
yearSuffix: Console.globalize.globalizeMessage(\"views/common/dates/text/year-suffix\"),
timeText: Console.globalize.globalizeMessage(\"views/common/dates/text/time\"),
timeOnlyTitle: Console.globalize.globalizeMessage(\"views/common/dates/text/time-only-title\"),
currentText: Console.globalize.globalizeMessage(\"views/common/dates/text/now\"),
closeText: Console.globalize.globalizeMessage(\"views/common/dates/text/close\"),
closeText: Console.globalize.globalizeMessage('views/common/dates/text/close')
};";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}