# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:'(views\/[^']*)'|\"(views\/[^\"]*)\")"
test_str = ("return {\n"
" dayNames: $(dayKeys).map(function(i, val){\n"
" return Console.globalize.globalizeMessage(\"views/common/dates/days/full/\" + val);\n"
" }).toArray(),\n"
" dayNamesMin: $(dayKeys).map(function(i, val){\n"
" return Console.globalize.globalizeMessage(\"views/common/dates/days/abrv/\" + val);\n"
" }).toArray(),\n"
" monthNames: $(monthKeys).map(function(i, val){\n"
" return Console.globalize.globalizeMessage(\"views/common/dates/months/full/\" + val);\n"
" }).toArray(),\n"
" monthNamesShort: $(monthKeys).map(function(i, val){\n"
" return Console.globalize.globalizeMessage(\"views/common/dates/months/abrv/\" + val);\n"
" }).toArray(),\n"
" hourText: Console.globalize.globalizeMessage(\"views/common/dates/text/hour\"),\n"
" minuteText: Console.globalize.globalizeMessage(\"views/common/dates/text/minute\"),\n"
" secondText: Console.globalize.globalizeMessage(\"views/common/dates/text/second\"),\n"
" millisecText: Console.globalize.globalizeMessage(\"views/common/dates/text/millisecond\"),\n"
" microsecText: Console.globalize.globalizeMessage(\"views/common/dates/text/microsecond\"),\n"
" timeSuffix: Console.globalize.globalizeMessage(\"views/common/dates/text/time-suffix\"),\n"
" yearSuffix: Console.globalize.globalizeMessage(\"views/common/dates/text/year-suffix\"),\n"
" timeText: Console.globalize.globalizeMessage(\"views/common/dates/text/time\"),\n"
" timeOnlyTitle: Console.globalize.globalizeMessage(\"views/common/dates/text/time-only-title\"),\n"
" currentText: Console.globalize.globalizeMessage(\"views/common/dates/text/now\"),\n"
" closeText: Console.globalize.globalizeMessage(\"views/common/dates/text/close\"),\n"
" closeText: Console.globalize.globalizeMessage('views/common/dates/text/close')\n"
" };")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.