use strict;
my $str = 'return {
dayNames: $(dayKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/days/full/" + val);
}).toArray(),
dayNamesMin: $(dayKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/days/abrv/" + val);
}).toArray(),
monthNames: $(monthKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/months/full/" + val);
}).toArray(),
monthNamesShort: $(monthKeys).map(function(i, val){
return Console.globalize.globalizeMessage("views/common/dates/months/abrv/" + val);
}).toArray(),
hourText: Console.globalize.globalizeMessage("views/common/dates/text/hour"),
minuteText: Console.globalize.globalizeMessage("views/common/dates/text/minute"),
secondText: Console.globalize.globalizeMessage("views/common/dates/text/second"),
millisecText: Console.globalize.globalizeMessage("views/common/dates/text/millisecond"),
microsecText: Console.globalize.globalizeMessage("views/common/dates/text/microsecond"),
timeSuffix: Console.globalize.globalizeMessage("views/common/dates/text/time-suffix"),
yearSuffix: Console.globalize.globalizeMessage("views/common/dates/text/year-suffix"),
timeText: Console.globalize.globalizeMessage("views/common/dates/text/time"),
timeOnlyTitle: Console.globalize.globalizeMessage("views/common/dates/text/time-only-title"),
currentText: Console.globalize.globalizeMessage("views/common/dates/text/now"),
closeText: Console.globalize.globalizeMessage("views/common/dates/text/close"),
closeText: Console.globalize.globalizeMessage(\'views/common/dates/text/close\')
};';
my $regex = qr/(?:'(views\/[^']*)'|"(views\/[^"]*)")/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}