import Foundation
let pattern = #"(?<=(/|^))(((/|^)|(\w*:))(?<node>.*?))(?=/|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
elem1/ns:elem2/ns2:elem3/@name
/elem/n:node1/node2/c:node3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*[local-name()='${node}']"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)