$re = '/(?<=(/|^))(((/|^)|(\w*:))(?<node>.*?))(?=/|$)/m';
$str = 'elem1/ns:elem2/ns2:elem3/@name
/elem/n:node1/node2/c:node3';
$subst = "*[local-name()='${node}']";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;