# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=(\/|^))(((\/|^)|(\w*:))(?<node>.*?))(?=\/|$)/*[local-name()='${node}']/gm;t' <<< "elem1/ns:elem2/ns2:elem3/@name
/elem/n:node1/node2/c:node3"