import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=(/|^))(((/|^)|(\\w*:))(?<node>.*?))(?=/|$)";
final String string = "elem1/ns:elem2/ns2:elem3/@name\n"
+ "/elem/n:node1/node2/c:node3";
final String subst = "*[local-name()='${node}']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}