#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=(/|^))(((/|^)|(\w*:))(?<node>.*?))(?=/|$)"
Local $sString = "elem1/ns:elem2/ns2:elem3/@name" & @CRLF & _
"/elem/n:node1/node2/c:node3"
Local $sSubst = "*[local-name()='${node}']"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)