use strict;
my $str = 'elem1/ns:elem2/ns2:elem3/@name
/elem/n:node1/node2/c:node3';
my $regex = qr/(?<=(/|^))(((/|^)|(\w*:))(?<node>.*?))(?=/|$)/mp;
my $subst = '*[local-name()=\'${node}\']';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";